Windows, high CPU/Memory, svchost.exe

    • Windows, high CPU/Memory, svchost.exe

      Hallo

      Im Rahmen der Probleme die wir auf Geschäftsrechner hatten, stelle ich die Problemlösungen für den Privatgebrauch jetzt einfach mal bereit. Privatrechner können davon leider auch betroffen sein (vorwiegend Win7/Win8..oder älter, heisst aber nicht, es bei Win10 nicht auftreten kann)

      Nachfolgendes löst folgende Probleme
      A)
      hoher CPU Verbrauch unter Windows der Prozesse "svchost.exe", in selteneren Fällen kann der Prozess auch den Arbeitsspeicher aufbrauchen.

      B)
      Nach Eingabe von Windows Benutzername+Pw dauert der Loginprozess übermässig lange. Direkt nach der Anmeldung, gleich wenn der Windows Desktop erscheint, ist möglicherweise unten rechts in der Taskleiste auf dem Netzwerkscenter-Icon ein sich "drehender blauer Microsoft Ring".

      Mögliche Folge; das Ausführen von Programmen kurz nach der Windows Anmeldung ist stark verzögert oder ausführen von Programmen überhaupt nicht mehr möglich, bis der blaue Ring verschwunden ist.

      Beides hat mit Windows Update-Komponenten zu tun, es kann A oder B oder beides gleichzeitig auftreten.

      Lösung für Problem A)
      1. Datei WMI_fix.txt (siehe Anhang) herunter laden und umbenennen in WMI_fix.cmd
      2. Mit einem User an Windows angemeldet sein der loakle Adminrechte hat
      3. Rechtsklick auf "WMI_fix.cmd" und im Kontextmenu "als Administrator ausführen" auswählen
      4. Das Skript läuft selbständig ab, warten bis es durchgelaufen ist, wenn erfolgreich, steht am Ende "DELETION SUCCESSFUL!" Bei Fragen oder Problemen Mayday fragen.

      Lösung für Problem B)
      Ein Thirdparty Script das auf der Microsoft Technetseite wer publizierte. Herunterladen hier:
      gallery.technet.microsoft.com/…ows-Update-Agent-d824badc

      1. Mit einem User an Windows angemeldet sein der loakle Adminrechte hat
      2. Rechtsklick auf "ResetWUEng.cmd" und im Kontextmenu "als Administrator ausführen" wählen.

      Gleich beim Start die Frage mit Taste Y für Yes bestätigen, im Menu Taste 2 Drücken für "2. Reset Windows Update Components", warten bis Vorgänge abgeschlossen sind.


      Nachtrag:
      Sollte das Technet Skript Meldungen ausgeben, dass Dienst(e) nicht gestoppt werden konnten, versuchen manuell zu stoppen. cmd als Admin starten und jede Zeile einzeln ausführen (copy paste), oder alles in ein cmd packen.
      net stop bits /y
      net stop wuauserv /y
      net stop appidsvc /y
      net stop cryptsvc /y

      Lässt sich ein Dienst noch immer nicht stoppen, den Dienst auf "deaktiviert" stellen, PC neu starten und "ResetWUEng.cmd" erneut ausführen. Dienste können auch in der cmd deaktiviert werden
      sc config bits start= disabled
      sc config wuauserv start= disabled
      sc config appidsvc start= disabled
      sc config cryptsvc start= disabled

      Nach der Reparatur nicht vergessen gestoppte Dienste wieder auf "automatisch" zu stellen, Beispiel: sc config bits start= auto
      Dateien
      • WMI_fix.txt

        (3,18 kB, 7 mal heruntergeladen, zuletzt: )

      Dieser Beitrag wurde bereits 13 mal editiert, zuletzt von _Mayday_ ()

    • Das hatte ich aktuell mit Win 10 auch, bei mir war es ein schlechter Treiber bzw. die Software meiner Netzwerkkarte der Firma KILLER. Hier einfach den neue direkt vom Hersteller runterladen (killernetworking.com/driver-do…/category/other-downloads) und ohne die Software, also nur den Treiber installieren. Dann war wieder alles gut.

      Gleiches/Ähnliches Phänomen: Arbeitsspeicher frißt sich voll und danach geht nix mehr. Auch nach reboot.

      BenQ W1070 3D Beamer & Yamaha RX-A3040 Aventage - Dolby Atmos in 7.1.4
      Was treibe ich zur Zeit neben Film und Fernsehen: Über mich